You Should Know...

To our customers:

The Heartbleed computer exploit has been prominent in the news recently. The vulnerability refers to software called OpenSSL, which is a type of ‘freeware’ software available to developers creating websites.

Community Bank, in tandem with our technology partners, has performed a thorough review of all systems we use within our environment. We have concluded that NONE of our systems use OpenSSL, and are confident that the Heartbleed exploit does not affect Community Bank’s systems, and therefore our customers, in any way.

If you would like more information, please contact our VP of Operations, Bob Ellison, at bobe@cboprf.com.

As always, we thank you for choosing Community Bank!

Update Your Email and Phone Number:For your security, please give us your current email address and phone number whenever you visit or call Community Bank.  Confirming your current contact information will help expedite your banking requests and provide you with peace of mind. 

Notice: By federal law, as of 1/1/2013, funds in a noninterest-bearing transaction account (including an IOLTA/IOLA) will no longer receive unlimited deposit insurance coverage, but will be FDIC-insured to the legal maximum of $250,000 for each ownership category. For more information, visit www.fdic.gov.

Fee-Free ATMs

Watch our video

Content on this page requires a newer version of Adobe Flash Player.

Get Adobe Flash player

FDIC-EDIE The Estimator

Want to be sure your accounts are FDIC insured? To help determine your FDIC insurance coverage, you can utilize our easy-to-use FDIC tool called EDIE The Estimator.

© 2007 Community Bank | Privacy Notice | Sitemap |